Issues at file hosting provider
Incident Report for Dropmark
Resolved
This incident has been resolved.
Posted over 2 years ago. Feb 28, 2017 - 19:26 EST
Monitoring
Our file hosting provider (Amazon S3) is reporting increased error rates in the US-EAST-1 region, which may affect file uploads and downloads. For more information see: https://status.aws.amazon.com
Posted over 2 years ago. Feb 28, 2017 - 13:28 EST