Broken thumbnails
Incident Report for Dropmark
Resolved
Back to normal!
Posted over 4 years ago. May 14, 2015 - 15:45 EDT
Monitoring
We have deployed new servers and are monitoring performance.
Posted over 4 years ago. May 14, 2015 - 15:42 EDT
Identified
We have identified an issue with our thumbnail servers and are working on a fix to bring service back online.
Posted over 4 years ago. May 14, 2015 - 15:33 EDT